CK Meringue Powder

Hi,

I am having issues since the last couple of days with my royal icing. I always use CK brand and use the same recipe and never had a problem like this. When the icing is mixed, I see beige dots or pieces through out the icing and when I try to pipe, it gets stuck in my tips. They are tiny but never before has this happened. 

Anyone experienced this before or what am I doing wrong?

Thanks 

Asmita

Original Post

Hi, I sometimes use CK royal icing mix (not meringue powder) when I need stuff to dry really puffy. I have always seen dark specks in it (more black than brown), but they seem to disappear over time and as the icing sets. BUT . . . lately (like in the last two weeks, with the last bunch I purchased), I have found it VERY gritty, not at all like it used to be. I imagine it is a manufacturing issue, and probably something to report to the company. I just haven't had the time. Also, before reporting, I was going to run through all that I have and check another batch (in another purchase) to see if it is a consistent issue, or just a one-off thing.

Put your royal icing in an unused, clean knee high stocking, then put that glob of icing into your bag.  Hold the bag and stocking tightly as you pull the stocking through your hand.  The stocking catches all those little crystals that didn't dissolve when mixing the icing.

 

JFW3 posted:

Put your royal icing in an unused, clean knee high stocking, then put that glob of icing into your bag.  Hold the bag and stocking tightly as you pull the stocking through your hand.  The stocking catches all those little crystals that didn't dissolve when mixing the icing.

 

Smart!

Econlady posted:
JFW3 posted:

Put your royal icing in an unused, clean knee high stocking, then put that glob of icing into your bag.  Hold the bag and stocking tightly as you pull the stocking through your hand.  The stocking catches all those little crystals that didn't dissolve when mixing the icing.

 

Smart!

Works like a charm. 

Asmita posted:

Hi,

I am having issues since the last couple of days with my royal icing. I always use CK brand and use the same recipe and never had a problem like this. When the icing is mixed, I see beige dots or pieces through out the icing and when I try to pipe, it gets stuck in my tips. They are tiny but never before has this happened. 

Anyone experienced this before or what am I doing wrong?

Thanks 

Asmita

yes, i have noticed the CK being "gritty" my last 2 purchases!

ShugRshack posted:
Asmita posted:

Hi,

I am having issues since the last couple of days with my royal icing. I always use CK brand and use the same recipe and never had a problem like this. When the icing is mixed, I see beige dots or pieces through out the icing and when I try to pipe, it gets stuck in my tips. They are tiny but never before has this happened. 

Anyone experienced this before or what am I doing wrong?

Thanks 

Asmita

yes, i have noticed the CK being "gritty" my last 2 purchases!

I reported several bad batch numbers directly to CK Products back in February 2018, and they said they would have their QC Department look into it and get back to me. They never did. I just emailed them with a reminder that I was awaiting a reply. I'd encourage you all to start reporting bad batch numbers to them too; then maybe they will consider doing something about it. It's a shame, because it used to work so well (for me), but now I avoid it.

So I heard back from CK Products today right after I issued my followup email, and they said they've changed to a finer sugar, so all is better now (see email below). In addition to taking them up on the offer of a sample (to test for myself before I buy again), I also asked for the starting lot number with this change, as I want to avoid old lots that may be troublesome. I'll keep you posted if/when I learn more.

Screen Shot 2018-04-20 at 4.48.12 PM

Attachments

Photos (1)

Add Reply

Likes (1)
ShugRshack
×
×
×
×